[Notice] Information regarding login issues
Followhello.
This is a MegaZone account.
On May 26, 2023, we would like to once again bow our heads in apology to customers who experienced inconvenience due to login issues with their MegaZone accounts.
The cause and current status of the issue are as follows.
Disability Content
2023-05-26 03:35 ~ 09:08
Google login is not possible
Root cause
Automatic patching occurred due to the minor version auto upgrade setting set in RDS.
During this process, the instance is restarted and RDS Failover is activated, and the read db is promoted to the write db.
The role of write db has changed to read db.
After this, all DCL requests sent to the Write DB Connection originally established by the Application Server resulted in an error.
Action taken
- Failover is performed by restarting the Read db that was promoted to Write and changing its role again.
- Disable automatic minor version upgrades for RDS
Follow-up actions
To prevent this issue from recurring in the future, we have implemented the following improvement measures:
- Change JDBC Driver to aws-advanced-jdbc-wrapper to support AWS Failover
- Consider using blue/green deployment when upgrading DB
- Strengthening the control team emergency contact network
We apologize again for any inconvenience caused.
We will strive to be reborn with more stable and better services.
Comments
0 comments
Please sign in to leave a comment.